Ticking noise Fox Evol DPS

PB Forum :: Mechanics' Lounge
Ticking noise Fox Evol DPS
Previous Page | Next Page
Author Message
Posted: Dec 17, 2016 at 12:14 Quote
Hello,

I have a Factory series Fox Evol DPS shock (2016) in my Santa Cruz 5010.
The bicycle is now +/- 12 rides old. (only used in The Netherlands, so no heavy usage)
The bike rides perfectly, but from the first ride it made some sort of ''ticking'' noice when riding over ''high frequency bumps''.

After a lot of searching (and swapping parts) we found the noice was in the shock. It makes a ''ticking'' sound between the compression and extension of the shocks stroke.

I'll send the shock to Sabma for a warranty repair. Today i used the shock again, but it was still making the sound unfortunately. (yes, all the bolts are torqued up right Smile ) With a other shock the bike was perfectly silent.

Does somebody has experience with this? Is it normal? or does the shock maybe need to wear-in ?

I have made movie of the ticking noice. (put volume high Big Grin )
https://youtu.be/A6tFtdOlwLI

Thanks in advance!

Posted: Dec 17, 2016 at 12:35 Quote
The other shock you used was the same Fox shock?? If it was, there's your answer

Posted: Dec 17, 2016 at 23:55 Quote
walkingtall76 wrote:
The other shock you used was the same Fox shock?? If it was, there's your answer

No it was not. It came out of a lower specced 5010. It was offcourse the same size shock. Also from fox, but without the Evol sleeve. Not kashima.

Posted: Nov 12, 2018 at 18:01 Quote
I have a brand new bike/shock making the exact same noise (also Fox Evol DPS). Did you ever figure this out?

Posted: Nov 13, 2018 at 8:42 Quote
Have you checked or replaced the shock bushings and hardware?

Posted: Nov 23, 2018 at 19:12 Quote
I checked the bushings and torqued the hardware. This was literally brand-new, straight out of the box frame and shock so there shouldn't have been any wear. The manufacturer is supposed to be sending me new parts just in case something was out of spec. I guess I'll wait and see...

Posted: Apr 14, 2021 at 16:06 Quote
Have the same problem with my 2020 Fox DPX2. Seems like a common problem?

Previous Page | Next Page

 
Your subscriptions
no posts

Copyright © 2000 - 2021. Pinkbike.com. All rights reserved.
dv56 0.005382
Mobile Version of Website