Strava import not working?

PB Forum :: Trailforks Feedback
Strava import not working?
Previous Page | Next Page
Author Message
Posted: Sep 17, 2019 at 18:41 Quote
Wierd, it usually works without fail but my last ride recorded with the Trailforks app didn't upload to Strava? Even if I resyc it doesn't show up, nor does the Strava icon on my Trailforks ride log for today's ride. All of a sudden started happening, no settings changed anywheres. Ideas?

Posted: Sep 17, 2019 at 18:42 Quote
Sorry, I just realized that I'm talking about an export to Strava, please forgive the thread title.

Mod Plus
Posted: Sep 17, 2019 at 23:27 Quote
It was broken for a few hours this morning, fixed it this morning. I ran the "Strava re-sync" on your ridelog and it uploaded to Strava now.

Posted: Sep 18, 2019 at 4:47 Quote
Killer! Thanks for everything you do, good sir!

Posted: Sep 19, 2019 at 6:27 Quote
Hi, I'm having the same problem, mind running the "strava re-synch" for me?

Posted: Sep 19, 2019 at 10:09 Quote
Same issue here, both yesterday's and today's rides have not uploaded to Strava....and yes, I've "syncd" both rides manually, no change.

Thanks for looking into the issue.

Mod Plus
Posted: Sep 19, 2019 at 22:01 Quote
OK I hopefully have a solution, not ideal though. If your account has an issue syncing a ride TO Strava I record this and then present a big red box on your profile, ridelog & settings pages.


We had to switch to a new Strava access token format and the migration of old tokens to the new ones isn't a 1:1 matching for permissions, so it seems that some people's new tokens don't have the proper write access. But there is no way for me to know this until it fails.

It's super annoying, when you request a token and the permission "scopes" you want for the token, the response doesn't actually tell you what scopes that token is granted! So I don't know if a user deselected some permissions when they connected their Strava account to Trailforks. Best I can do is detect when there is an error with the token for a specific action requiring a certain permission. I'm saving write errors to a DB table, so I can show the above message to the user.

The only fix is to re-connect your Strava, requesting a new access token with the correct permissions granted.

Posted: Sep 20, 2019 at 12:27 Quote
Thank you - successfully sync'd my past 3 rides with Strava! Will post again after my next ride to confirm it does so automatically.

Previous Page | Next Page

 
Copyright © 2000 - 2019. Pinkbike.com. All rights reserved.
dv65 0.006916
Mobile Version of Website