Easton Haven Dropper Issue

PB Forum :: Mechanics' Lounge
Easton Haven Dropper Issue
Previous Page | Next Page
Author Message
Posted: Dec 8, 2019 at 23:54 Quote
Hi all

I installed my Haven dropper this morning on my new frame. Now when I put any weight on it it just slips down without the remote being pressed. I’ve had this before and did the brake reset, which worked but isn’t now. I’ve made sure the cable is the right tension etc. too but still not able to get it working.

Any thoughts on what else it may be? Anyone have one and had the same problem?

Any help appreciated.

Posted: Dec 17, 2019 at 16:24 Quote
Did you ever solve your problem? My easton haven dropper post did the same thing. Take the post out of the frame and completely disconnect the cable from the post. put the post on the ground and push down to see if the post still slips down. If it still slips down(mine did) then contact easton/raceface for warranty. They ended up sending me a brand new raceface dropper post that has been working great for months now

Posted: Dec 18, 2019 at 4:35 Quote
Not solved yet. Will try that though. It was ok when disconnected in my new frame but that was a few months ago. Decided to buy a new post anyway as I was getting annoyed at always doing the brake reset as easy as it is.

Posted: Jan 1, 2020 at 5:57 Quote
So, I installed my new dropper and the Easton is still not working when disconnected so definitely something wrong. Need to check if I can warranty it or not now.

Previous Page | Next Page

 
Your subscriptions
no posts

Copyright © 2000 - 2020. Pinkbike.com. All rights reserved.
dv65 0.004378
Mobile Version of Website